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Preface

When I finished my Master’s degree in Microelectronics I founded a company called

Intelligent Agent together with my partner Elias. We wanted to make high-tech

stuff so we started a company to provide radar sensors for robots. This meant we

had to develop and build both advanced digital circuits and RF circuits.

We didn’t have any money saved up and we didn’t have any investors so we needed

to build our circuits as cheap as possible. During this time we learned a lot about

how to get circuit boards made as cheap as possible and lots of other hands-on

experience of building electronic circuits on a budget.

This book is an effort to share my knowledge so that more people can enjoy the

fulfillment of creating cool electronic circuits.

I remember when I studied electronics at the university. I actually didn’t build my

own printed circuit board before I was at my third year! By then, I knew some

pretty advanced electronics theory, but I did not know how actually to build the

stuff I was learning about.

If you think getting a PCB manufactured is too expensive or that you need ex-

pensive and fancy equipment to create professional looking electronics, then think

again. You can actually build some pretty advanced circuits with very little money

and very basic equipment.

Some discoveries I have made that I will share with you in this book include:

• You can find free schematics for almost anything

• Creating a PCB design is easy

• Getting professionally made printed circuit boards can cost as little as $1

per board!



Who Is This Book For?

This book is an introduction to the field of making PCB’s and is aimed at people

who want to get started on creating their first prototype PCB’s.

It doesn’t matter how much or how little electronics theory you know. In this

book you will learn the practical steps of creating a PCB independently of your

electronics theory knowledge.

How To Use This Book?

This book is designed as a practical hands-on guide with some additional infor-

mation on how to create your first PCB’s.

To get the most out if this book I recommend that you first spend five minutes

to browse quickly through the material to get an overview. Then start from the

beginning and follow the instructions along the way.

Keep the book as a reference for later until you have the process saved in your

fingertips.

The content for this book is based on articles from my website:

www.build-electronic-circuits.com

www.build-electronic-circuits.com


How To Support Me

I’ve decided to give out this book for free for now. If you’d like to support me,

please consider purchasing one of my other products:

Build Your Own Electronic Gadgets

With this online course, you’ll learn to build cool and fun projects like music-

playing devices, lamps that connect to the internet, and more:

www.build-electronic-circuits.com/build-your-own-electronic-gadgets-info/

Getting Started With Electronics

Learn electronics from scratch with this easy-to-read eBook – and build things like

blinking lights, alarms, sound-effect generators, and much more:

www.build-electronic-circuits.com/getting-started-ebook-link

www.build-electronic-circuits.com/build-your-own-electronic-gadgets-info/
www.build-electronic-circuits.com/getting-started-ebook-link


1 Introduction to Making PCB’s

Many hobbyists believe that getting a circuit board manufactured is too expensive

or too hard. I thought so too, until I had no choice but to figure out how to do it

on the cheap.

Some prototype manufacturers actually offer 10 boards for $10. That is only $1

per board!

1.1 What is a PCB?

A Printed Circuit Board (PCB) is a board that connects electronic components

through electrical pathways on the board itself. Example:

More than one way exists to make a PCB. You can etch boards at home, but I

find this messy, unreliable and not worth the effort. You can use a CNC router to

create boards, but these machines are usually expensive and vias tend to be much

more extra work. Or you can just get your design manufactured by a professional

manufacturer for the price of a few bananas. I prefer the latter method ;)



1.2 Why Build a PCB?

If you want to build electronic circuits you need to connect the components of your

circuit. If you expect to make your circuit work more than just a few times you

need a solid way of connecting them. You need to create a PCB.

I started playing with electronics as a hobby when I was 14. Since then I have

finished a Master’s degree and founded two electronic design companies. I have

learned that creating a PCB can be both simple and cheap! And of course much

more fun =)

1.3 ”Surface Mount” or ”Through-Hole”?

When you design a PCB, you need to decide if you want to use ”surface mount”

or ”through-hole” components. You can also use a combination of both. Surface

mount components are soldered on the surface of the PCB while through-hole com-

ponents are soldered on the back side of the board with the pins of the component

going through holes in the board.

What’s the difference?

Through-hole components are easier to solder, but take up more space. Surface

mount components are harder to solder, but can drastically reduce the amount of

space needed. If space is not an issue for you, I’ll recommend using through-hole

components.

1.4 Layers

A PCB can have many layers. In this book, I will you show how to create a two-

layer board. This means the board will have a top layer and a bottom layer that



can be used to create traces.

1.5 Overview

This book will cover the three following phases for creating a PCB:

• Schematic

• Board Layout

• Manufacturing

Schematic

You start with an idea of something you want to create. The first step is to find

a schematic diagram for this idea. Then you draw this into an Electronic Design

Automation (EDA) software of your choice.

Board Layout

You have created your schematic and the next step is to create a board layout

from this schematic. This is also done in an EDA software.

Manufacturing

With your board layout ready you do some final tests to check for any errors on

your board. When the board passes the tests you create Gerber files and send

them to a PCB manufacturer of your choice.

PCB manufacturer.



2 Introduction to Cadsoft Eagle

Throughout this book, we will use an Electronic Design Automation (EDA) soft-

ware called Eagle. Eagle is available as freeware for Windows, Linux and Mac.

Note: The instructions given in this book is for Eagle version 5, but should work

with any version of Eagle.

2.1 Download and Install

To download and install Eagle go to the Cadsoft homepage. You can find the link

in the resources section. Here you will find instructions on how to download and

install Eagle on Windows, Linux and Mac.



2.2 Control Panel

The first window you will see when starting Eagle is the Control Panel.

The Control Panel is where you manage all your

• libraries

• scripts/jobs

• projects

• schematics

• layouts



If you want to add a new schematic, board layout, project or library, click on

File → New

Libraries are collections of component definition. A component consists of a symbol

(for the schematic diagram), a footprint (for the board layout) and information

about how these are connected. Eagle ships with a bunch of libraries included,

but you can also make your own libraries or download libraries online (check out

the links section).

2.2.1 Directories

Eagle looks for project files in specified directories. If you want to add or change

which directories where the project files are located, go to Options → Directo-

ries. Locate the ”Projects” edit box and change this into the desired directory.

To specify more than one directory separate the directory paths with a ”:” (colon).



2.2.2 Automatic Backup

By default, Eagle creates automatic backups. The backups are saved in the same

directory as the schematic and layout files.

Backup files end with ”.s#1” (schematic files) or ”.b#1” (board layouts). The

default setting creates up to nine different backup files for both schematics and

layouts. You can change these settings in Options → Backup...

2.3 Schematic and Board Layout Window

There are two tools you use in order to design circuits in Eagle. The Schematic

Window and the Board Layout Window. The Schematic Window allows you to

create a schematic diagram of the circuit you want to create. The Board Layout

Window allows you to design the board layout of your circuit.

To open the schematic editor or the board layout editor you need to open or create

a new schematic or board. In the Projects/examples/ folder in the Control Panel

you will find examples that you can play around with.



2.3.1 Toolbar

On the left side of the schematic and layout editor there is a toolbar

with a selection of different tools and commands to create your circuit.

To use a command click on the icon of the command you want to

use then click on the object to use it with or somewhere in the editor

window.

Example: Move

1. Click on the ”Move” icon.

2. Click on the red cross of the object you want to move.

3. Move the object to its new position and click your left mouse

button again.

Note: If there are several objects in the nearby, Eagle cannot know which object

you want to select. So, one object will be highlighted. If this is the object you want

to select click again to select it. If this is not the object you wanted right-click

and a different object is highlighted. Keep right-clicking until the correct object is

highlighted then left-click to select.

Group move

To perform an action on more than one object this is what you have to do:

1. Click the ”Group” icon.

2. Select the objects you want either by dragging and dropping a rectangle over

the objects or by left-clicking several times to create a polygon around the

objects then do a right-click.



3. Click on the desired action icon. For example ”Move”.

4. Hold the Ctrl-key on your keyboard while right-clicking with your mouse.

You should now be able to move all the selected objects.

5. Left-click to place to group at the new location.

2.3.2 Useful Tools

Add

Add a part from the library to your schematic. Left-click on the ”Add”-icon to

fetch recently used components.

Copy

Create a copy of one or more objects.

Info

View and edit information about a component or wire.

Value

Change the value of a component.

Name

Change the name of a component or a wire. If you give two or more wires the

same name Eagle connects these wires. So if you want to connect wires without

having to draw a wire between them you can give them the same name.



Smash

Separate the labels and the rest of the component. This enables you to move the

labels of your component independently of the symbol or device package. Useful

for cleaning up when designing layouts.

Net (Schematics editor only)

Create wires between components.

”Net” vs ”Wire”: Be aware that the ”Wire” command also creates connections,

BUT it does not create junctions (the green dots) automatically. Therefore, always

use ”Net” to make connections.

Label (Schematics editor only)

Creates a name-label of the net you choose. Use labels often to make your

schematic more readable.

2.3.3 Shortcuts

Eagle offers the possibility of assigning keyboard shortcuts for quick access to

commands and scripts. Click on Options → Assign.. for a list of available

shortcuts. Here you can also add your own shortcuts.

2.3.4 Command Line

The eagle command line is for entering commands. You can enter any tool name

into the command line as a substitute for clicking its icon. Some of the commands

accept parameters. Find out more about the parameters of a command by typing

”HELP” before a command. E.g. ”HELP MOVE”



It is also possible to run scripts from the command line. Type ”RUN” and the

name of the script. E.g. ”RUN length”



3 Designing Schematics

Back when I was just starting out with electronics I did not know any electronics

theory at all. I started out with some simple circuits that my father drew on a

piece of paper for me that contained relays and capacitors to make a light blink.

I connected the components using wires and an old, used circuit board that I

drilled holes in. I was in ecstasy when I made it work! And I got hooked. I needed

more circuits.

I started looking on the Internet and found that I could find schematics to all

kinds of circuits. When I realized this, it was like I had found a secret treasure!

I was now in possession of information on how to build electronic circuits for all

kinds of devices.

In this section I will go through the steps of creating a schematic diagram for a

circuit and explain how to draw it in Eagle.

3.1 Step 1: Find Schematics

The first step when building an electronics project is to find or design schematics

for the device you want to build.

But there is no need to reinvent the wheel by designing the schematics from scratch.

You can start with a complete circuit where you only need to do minor changes

(if any) or you can combine several smaller circuits into a larger one.

Either way you usually start of with one or more schematics that you have found

in a book or on the web somewhere then you draw this into your EDA software.

Through the years of building electronics I have found several good resources for

free schematics. In the resources section I have assembled a list of websites with

free schematics.



3.2 Step 2: Check Part Availability

You should always verify that the components for your circuit are available before

you do too much work. I like to order components from one of the many available

online component distributors. A quick search lets me know if they have the

component or not.

A list of my favorite online component stores is in the resources section at the end.

If the schematics you have found includes components that are not available to

you, use Google to search for replacement parts.

3.3 Step 3: Draw Your Schematic in Eagle



The above schematic is a circuit for making two Light Emitting Diodes (LED)

blink. It is called an ”Astable Multivibrator”. We will use this circuit as an

example for the rest of the book.

So, we have a picture of the circuit we want to build. I will refer to this as the

original drawing of our circuit.

Now we need to recreate the schematic diagram in Eagle.

Create New project and Schematic

We start by creating a new project and a new schematic in Eagle. Open Eagle’s

Control Panel and choose File → New → Project from the menu to create a

new project.



Add a new schematic to the project by selecting File → New → Schematic

from the menu. You now have a blank schematic ready for drawing.

Add Parts

The next step is to add the components to our schematic. Let us start by adding

four resistors.

Select Edit → Add.. from the menu in the schematic editor. The ”ADD” dialog

box appears.

We want to locate a resistor. Write ”resistor” in the search field and press Enter.

You will probably find many alternatives. I chose a through-hole resistor called

R-EU 0207/10 from the ”resistor”-library. Choose one and press ”Ok”.

Place the resistor on your schematic by left-clicking. Do this four times to get four

resistors. Press ESC to return to the ”ADD” dialog box.



Continue to add the capacitors, transistors and LEDs from the original circuit

drawing in the same way.

Tips: To place the two transistor as mirrors to each another like I did, use the

Mirror function (Edit → Mirror..) from the menu.

Add Power Connection

Your circuit also needs a power connection. In this example, we will add a two-pin

header for connecting power and ground.

Go to the ”ADD” dialog box and search for ”2 pin header” to find a suitable part

in the ”con-molex” library. Add this part to your schematic diagram.



Set Component Values

Now we will add values to the components. We want to set the resistance of the

resistors and the capacitance of the capacitors. To do this choose Edit → Value..

from the menu. Then click on the component you want to set the value for.

Enter the value and press ”Ok”. Set values for all the resistors and the capacitors.

Use the values from the original drawing of our circuit.



Add Connection Between Components

We need to add wires between the components to make connections between them.

Choose Draw → Net from the menu and draw wires between the components as

shown in the original circuit drawing.

To draw diagonal lines, choose the second ”Wire bend” button from the toolbar

when the ”Net” tool is selected.

Tips! The ”Wire” tool does not always create the electrical connection you want

so make it a habit always to use the ”Net” tool instead.



You should now have a schematic diagram similar to the screenshot above.

Electrical Rule Check (ERC)

Before we are ready to move on to board layout we should run an ERC to check

for any mistakes that need to be fixed.

Select Tools → ERC from the menu. When I run the ERC I get two warnings

telling me that the LEDs do not have any defined values.



I choose not to define any values for the LEDs so I click ”Approve” on both of

them. Fix or approve any warnings or errors you receive before going any further.



4 Board Layout

We now have our schematic diagram in Eagle. We are ready to design the board

layout for our circuit. But first, let us look at some basic design guidelines.

4.1 Design Guidelines

4.1.1 Board Size and Trace Width

A limit always exists on how large your board can be, how thin your traces can

be and the minimum drill size you can use.

Check the capabilities of you PCB manufacturer. They usually put this informa-

tion out on their web page. Sometimes they supply a Design Rule Check (DRC)

file that you can load right into Eagle. Below is an example of the manufacturing

rules of Seeed Studio.



Your board size must not exceed the capabilities of the manufacturer you have

chosen.

Your trace width must be at least the size of the minimum allowed trace width,

but should generally be thicker because thin traces are more vulnerable to damage

when soldering. The more current that is going to flow through the trace the

thicker it should be. If you have a lot of space on your circuit board start with 20

mil trace width for signals and 30-40 mil for power traces.

4.1.2 Placement of Components

Place the components in the same way as in your schematic diagram if possible.

This makes it much easier to troubleshoot the circuit if needed later on.

Pay attention to connectors and large components. Connectors should be placed



on the side for simple connection. If you are going to place the finished PCB in

a box keep in mind any large components and how they will fit in the box when

you are going to assemble your electronic project.

4.1.3 Labels

Your components should all have labels with names and component values printed

on the board if possible. This makes it much easier to solder the circuit board and

to troubleshoot it later on.

A useful rule-of-thumb is always to label connectors that are going to connect to

something outside the board with descriptive names. Add names for each pin on

a pin header.

4.1.4 Horizontal and Vertical Routing

If you are using a two-layer circuit board with a bit of complexity, a useful guideline

to follow is to route one layer horizontally and the other vertically.



4.2 Creating a Board Layout

Now, let us look at how we can create a board from the schematic we created in

the last chapter. In this example, we will create a two-layer board. That means

we can draw traces on both the ”Top” layer and the ”Bottom” layer.

We start by opening the schematic diagram that we want to create a board for.

Click on the ”Board” button (or choose File → Switch to board from the menu)

to create a board for this schematic.



If no board exists, we will get a warning asking us to create a new board.

Choose ”Yes”. A new board is created based on your schematic diagram.

You will find all the components you have added on the left side. The rectangle in

the middle defines the board outline. Use the ”Move” command to edit it if you

want to change your board size and/or form factor.



4.3 Placing The Components

We choose the ”Move” action from the toolbar (or the ”Edit” menu) to place the

components on our board. A good way to arrange our components is to place

them similar to the placement in the schematics. This makes it much easier to

troubleshoot the circuit at a later stage if needed.



Place all the components within the board limits and arrange them in the same

way as the schematic.

The yellow lines between the components are ”airwires” and they show you the

shortest path of a pin to where it is to be connected. When you move the compo-

nents the airwires needs to be updated to show correct info. Click on ”Ratsnest”

from the ”Tools” menu to update the airwires.

4.4 Routing The Board

With the components placed, we are ready to begin routing the board.

4.4.1 Routing Options

There are two options to routing the board.

You can use the Autorouter to automatically route your board or you can route it

manually. The Autorouter is found in the ”Tools” menu (Tools → Auto...). I like

to route my boards manually. Mostly because I think the Autorouter makes very

ugly boards. And also, the Autorouter doesn’t always work for complex circuits,

so it’s better to learn to route manually from the beginning.

In this example we will route our board manually.

4.4.2 Manual Routing

Choose ”Route” from the toolbar (or from the ”Edit” menu). Select 16 mil trace

width and 24 mil drill size.

A rule-of-thumb is to use wide traces for nets that draw a lot of current, for example



your power lines. For other nets, we can use thinner traces. In this example, the

circuit does not draw much current, so we just choose some default values.

We start routing by clicking on one of the yellow airwires. A trace appears with

a color corresponding to the current routing layer. Now we use our left mouse

button to route the wire to where the airwire points us.

If we want to change the routing layer we simply click the middle mouse button

or use the layer selector on the toolbar. If you change routing layer while routing,

a via to the next layer is created.

As mentioned earlier, it can be smart to route only horizontally on one layer and

only vertically on the other. But this is not necessary for such a simple board as

in this example.



When you have finished routing all the airwires on your board you are ready to

prepare the board for manufacturing.



5 Manufacturing your PCB

Before you send your board layout to PCB manufacturing you should run some

tests to minimize the risk of errors. There is always a chance of errors when you

design a board.

Actually, errors are common with prototype boards. And often you do not discover

it before you have manufactured the circuit board and are trying to troubleshoot

it.

You can avoid many errors by making sure the schematic diagram is correct. So

triple-check your schematic diagram. When you are sure your schematic is correct

go ahead and do the following tests.

5.1 PCB Error Checking

5.1.1 Check for Unrouted Nets

When you are routing a board layout with many connections it is easy to overlook

a wire. You should always be 100 % sure that you have routed all your nets before

sending a board to PCB manufacturing. If there is an unrouted net on your board

you might run into some serious headaches when troubleshooting your circuit.



Luckily, there is a tool to help us. You can check for unrouted nets by running the

script called ”length”. Type ”run length” in the command line to start the script.

It will show a list of all your nets and which ones you have not routed yet.

If there are any unrouted nets you can locate them by typing ”show net name”

(change net name to the name of the net you want to find) in the command line.

5.1.2 Schematic/Board Layout Consistency Check

Always make sure your board layout and schematic stay consistent. This means

that their set of parts/elements and nets/signals must be equivalent.

In Eagle, the ERC does the consistency check. Choose ”Tools” in the top menu

and click on ”ERC”. If there are no errors nothing happens except for a text in

the bottom of the screen saying ”no errors/warnings”.



5.1.3 Test Design Rules

Use the Design Rule Check (DRC) to make sure your drill holes, trace widths,

spacings and such are within the capabilities of your PCB manufacturer. Either

use a supplied DRC file from you manufacturer or put in the design constraints

manually.

In Eagle, choose ”Tools” in the top menu and click on ”DRC”. Here you can either

load a DRC file or enter the numbers manually. It might look at bit overwhelming

to enter the constraints manually, but if you take your time, it should be fairly

easy to do it.

Run the DRC by clicking the ”Check” button. If there are no errors nothing

happens except for a text in the bottom of the screen saying ”DRC: No errors”.

5.2 Generate Files For Manufacturing

When you have successfully run the above tests you are ready to generate files to

send to manufacturing.

The Gerber format is the file format you use when you want to get your PCB

made. By creating Gerber files from your board layout, all the manufacturers

can view the layout you have designed. Gerber files are just images of your PCB

in a format called RS-274X and they give you freedom to choose whatever PCB

software you want.

Let us go through the process of creating Gerber files step-by-step.



Step 1: Open the CAM Processor

In the board layout window click the ”CAM” button or choose File → CAM Pro-

cessor. This will open the CAM Processor tool for generating the Gerber files.

Here you specify which layers you want to create Gerber files from. But it is not

necessary to understand this tool. I have always been using ready-made configu-

rations without giving much thought to what is going on. And that is probably

what you want to do as well.

Step 2: Open a predefined job

Eagle comes with a predefined job for making Gerber files. Its name is ”gerb274x.cam”.

To open it in the CAM Processor click File → Open → Job.... Browse to your

”eagle” directory and locate the ”cam” folder. Here you should see a file called

gerb274x.cam. Choose it and click ”Open”.



You will see five tabs in the CAM Processor. Each of these tabs will generate a

Gerber file.

Can’t find the ”cam” folder? Go to the Control Panel. Select Options → Di-

rectories from the menu. In the ”CAM Jobs” edit box you can see the location

of your ”cam” folder.

Step 3: Adding a second silk screen (Optional)

If you look closely at the tabs you will see that you do not have a file for silk screen

bottom. For simple boards, the silk screen is usually only on the top layer so that

you do not need the bottom. Some of the cheap circuit board manufacturers do



not even allow bottom silk screen.

But if you need silk screen on bottom layer as well, follow these steps:

1. Click ”Add”

2. Change Section to ”Silk Screen SOL”

3. Change File to ”%N.pls”

4. Deselect all layers

5. Select layers 20 ”Dimension”, 22 ”bPlace” and 26 ”bNames”

There you go. The job is updated with a new output file.

Step 4: Process the job

Now it is time to process the job.

Select where you want to put the Gerber files by clicking on the ”File” button and

choosing a folder. Do this for all the tabs.

Click ”Process Job” and your Gerber files are created in the folder(s) you have

specified.

Step 5: Adding file for drill holes

Even though drilling is supported by the Gerber format manufacturers usually

want the Excellon file format for specifying drill holes.

Luckily, Eagle also comes with a predefined job for creating a drill file. Open it in

the CAM Processor by clicking File → Open → Job.... Browse to your ”cam”

folder, and open the file named ”excellon.cam”.



Select where to put the output file by clicking on the ”File” button. Then click

”Process Job” to create your Excellon file.

Step 6: Check output files

You should now have the following files:

• *.cmp (Copper, component side)

• *.drd (Drill file)

• *.dri (Drill Station Info File) - Usually not needed

• *.gpi (Photoplotter Info File) - Usually not needed

• *.plc (Silk screen, component side)

• *.pls (Silk screen, solder side) - If you added it in step 3

• *.sol (Copper, solder side)

• *.stc (Solder stop mask, component side)

• *.sts (Solder stop mask, solder side)



5.3 Gerber Viewer

If you want to take a final look at your design to make sure everything looks ok

before you send it to production you can load your Gerber files into a Gerber

Viewer. A Gerber Viewer will let you see exactly what the manufacturer will

create, layer by layer.

A link to a free online Gerber Viewer is available in the resources section.

5.4 Order PCB Prototypes

If everything looks ok, you are ready to send your board to production. I have

compiled a list of cheap prototype manufacturers in the resources section.

Choose a manufacturer that you like and follow their instructions on how to send

them your Gerber files. This is usually done by email, a web upload or through a

custom software.

Now, give yourself a pat on the back, you have just ordered a professional manu-

factured circuit board!

5.4.1 PCB Assembly

PCB Assembly (PCBA) is the process of soldering the components to your board.

Many manufacturers offer this as an option so that you do not have to solder

yourself. So far, I found that this is usually quite costly as a hobbyist.

Anyway, soldering is so much fun, so no need to pay anyone for doing the fun for

you ;)

You can find free tutorials on how to solder on my website:

http://www.build-electronic-circuits.com

http://www.build-electronic-circuits.com
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7 Resources

Many free articles, tutorials and guides are available on my website:

http://www.build-electronic-circuits.com

The rest of this section I dedicate to a collection of resources that I find useful

when building electronics.

7.1 Free Schematics

Check out the following page for a list of websites with free schematics:

www.build-electronic-circuits.com/free-electronic-circuits

7.2 Component Distributors

Check out the following page for an updated resource on where to get tools and

components:

www.build-electronic-circuits.com/components-and-tools/

7.3 Electronics Forums

Links to discussion forums where you can get help or help others with electronics

related issues:

• http://www.edaboard.com

• http://www.electronicspoint.com

• http://forums.parallax.com

• http://forums.hackaday.com

http://www.build-electronic-circuits.com
www.build-electronic-circuits.com/free-electronic-circuits
www.build-electronic-circuits.com/components-and-tools/
http://www.edaboard.com
http://www.electronicspoint.com
http://forums.parallax.com
http://forums.hackaday.com


• http://www.eevblog.com/forum

• http://www.electronics2000.co.uk/forum

7.4 PCB Manufacturers

Seeed Studio

http://www.seeedstudio.com/depot/fusion-pcb-service-p-835.html

Seeed Studio are based in China. Their PCB service is called Fusion and it is my

number one choice for simple PCB prototypes. Cheap and friendly. $10 USD for

ten boards. That is one dollar per board! Plus shipping. It usually takes about

three weeks to get the boards delivered to Norway.

Olimex

http://www.olimex.com/PCB/

Based in Bulgaria. They offer OK, prices, but their price list is a bit hard to

understand. I used to order from them a couple of years back and was happy with

their service.

iTeadStudio

http://imall.iteadstudio.com/open-pcb/pcb-prototyping.html

I have never tried their service, but their prices are as low as Seeed Studio and

they also offer 4-layer boards.

OSH Park

http://oshpark.com/

http://www.eevblog.com/forum
http://www.electronics2000.co.uk/forum
http://www.seeedstudio.com/depot/fusion-pcb-service-p-835.html
http://www.olimex.com/PCB/
http://imall.iteadstudio.com/open-pcb/pcb-prototyping.html
http://oshpark.com/


I have not tried them, but their prices seem fair and you can upload your Eagle

design directly without having to convert to Gerber files. And they claim to make

good quality boards.

PCB Cart

http://www.pcbcart.com/

A Chinese PCB and Assembly service. I have not tried them, but I hear they can

offer really good prices. You can get an online instant quote if you want to check

their prices.

http://www.pcbcart.com/


7.5 Books and Courses

I’ve decided to give out this book for free for now. If you’d like to support me,

please consider purchasing one of my other products:

Build Your Own Electronic Gadgets

With this online course, you’ll learn to build cool and fun projects like music-

playing devices, lamps that connect to the internet, and more:

www.build-electronic-circuits.com/build-your-own-electronic-gadgets-info/

Getting Started With Electronics

Learn electronics from scratch with this easy-to-read eBook – and build things like

blinking lights, alarms, sound-effect generators, and much more:

www.build-electronic-circuits.com/getting-started-ebook-link

www.build-electronic-circuits.com/build-your-own-electronic-gadgets-info/
www.build-electronic-circuits.com/getting-started-ebook-link


7.6 Other Links

Online Gerber Viewer

http://www.gerber-viewer.com/

Download Cadsoft Eagle

http://www.cadsoftusa.com/download-eagle/

Download Libraries for Eagle

http://www.cadsoftusa.com/downloads/libraries?language=en

http://www.gerber-viewer.com/
http://www.cadsoftusa.com/download-eagle/
http://www.cadsoftusa.com/downloads/libraries?language=en
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